GETTING STARTED WITH FRAMING DESIGN
# TABLE OF CONTENTS

1. Introduction ................................................................................................................... 4  
2. User Interface ............................................................................................................... 5  
   2.1. Navigating Within the Modeling Window .............................................................. 7  
   2.2. Editing Model Object Properties ........................................................................... 8  
3. Introductory Concepts .................................................................................................. 9  
4. Recommended Gravity Framing Design Steps ........................................................... 11  
5. Framing Design of Example Project ........................................................................... 12  
   5.1. Start a new project & input Project Information ..................................................... 12  
   5.2. Attach Architectural Plans .................................................................................... 13  
   5.3. Define Levels ........................................................................................................ 15  
   5.4. Draw First Level Walls ........................................................................................ 16  
      5.4.1. Drawing Single Straight Wall ........................................................................ 17  
      5.4.2. Drawing Walls by Polyline ............................................................................ 19  
      5.4.3. Interior Walls ................................................................................................ 21  
      5.4.4. Adding Wall Openings .................................................................................. 23  
   5.5. Draw Second Level Walls ..................................................................................... 26  
   5.6. Layout of Roof Framing ......................................................................................... 28  
      5.6.1. Roof Framing Area ........................................................................................ 29  
      5.6.2. Roof Girder Trusses ...................................................................................... 30  
      5.6.3. Fill Roof Framing ........................................................................................... 38  
   5.7. Layout of First Level Framing ................................................................................ 45  
      5.7.1. First Level Floor Framing Area ..................................................................... 45  
      5.7.2. First Level Floor Joists .................................................................................. 46  
      5.7.3. First Level Beams ......................................................................................... 47  
      5.7.4. Low Roof Framing ......................................................................................... 52  
   5.8. Analysis and Design ............................................................................................... 56  
      5.8.1. Running the Analysis .................................................................................... 56  
      5.8.2. Reviewing Results Overview ......................................................................... 57  
      5.8.3. Review of Header Designs ............................................................................. 58  
      5.8.4. Review of Floor Beam .................................................................................. 62  
      5.8.5. Floor Joist Redesign ...................................................................................... 62
5.8.6. Framing Reports ................................................................. 65
5.8.7. Export Structural Plans as CAD File ............................ 67
5.9. Introduction to Section Groups ........................................ 67

( Doc Rev: 12.22.10 )
1. **Introduction**

This *Getting Started Guide* is an introduction on how to use the BuildingWorx 2011 design suite. In this document, the reader will find an overview of the user interface, a description of the recommended design steps, and a step by step example of how to use the design software on a simple example project.

BuildingWorx is a Building Information Modeling (BIM) based application. Objects (walls, openings, beams, etc) in BIM have physical, analytical and behavioral properties. This allows great deal of automatic interaction between objects (for example detecting wall intersection and use of a single hold-down at corners). However, it also puts limitations on acceptable editing. Only editing that makes physical and analytical sense will be acceptable. Editing that results in objects losing their connections to other objects will result in warnings and may generate error messages. After a few projects, users become familiar with the behavioral aspects of objects in BIM and are able to differentiate them from CAD objects.
2. **User Interface**

Figure 2-1 shows the general layout of the User Interface in BuildingWorx.

**Menus:** The menus at the top of the software window are the typical menu-type interface. Most, but not all, user actions can be initiated through the menus. Shown to the left of some menu entries are Icons that are used to represent the menu action in the short cut toolbars. Shown to the right of some menu items are keyboard short cuts that can be used to initiate the menu action.

**Toolbars:** Below the menus are the shortcut toolbars populated with icons used to initiate many of the most common user actions. If you hold the mouse cursor over a toolbar icon, a short description of the action will be displayed. It is highly recommended that while you learn the software that you take a little time to explore what actions are available in the toolbars.

**Object Visibility:** The Object Visibility toolbar is a special toolbar is located at the left edge of the software interface. The icons on this toolbar control what types of objects are visible in the graphics area of the software. The behavior is similar to showing and hiding layers in a CAD tool. Again, holding the mouse cursor over a toolbar icon will display a short description of the action initiated by the toolbar icon.

**Hint Area:** The white space near the bottom of the software interface is an area where messages to the user are displayed. One common use of this area is to display information, or hints, to the user during a multi-step editing action. This area is also used to show the status of the analysis process.

**Snap Control:** The buttons of the snap control area at the bottom of the interface are a very useful way to change the behavior of the cursor and selecting points within the graphical modeling area. The behavior of selecting points is similar to many CAD tools where the user can snap to points orthogonal to objects (Ortho) or end and corners of existing objects (OSnap). If you are not familiar with these types of snap behaviors from a CAD tool, it is recommended that you experiment with the different options to understand how they impact the cursor selection behavior.

**Object Properties:** When an object is selected in the graphical modeling area, the object properties area will show many properties of the object. The object properties are organized in a tree hierarchy with some branches of the tree not expanded by default. Typically properties can be edited by left clicking on the property value in the right column of the object properties pane. When displaying analysis results, the Properties area is also used to control what output results are shown by selecting the Output Tab.

**Modeling Area:** The modeling area of the user interface is the main window to view the structural design model you are creating and many of the results of your analysis and design.
FIGURE 2-1: USER INTERFACE LAYOUT IN BUILDINGWORX
2.1. **Navigating Within the Modeling Window**

Use of a three button mouse with a center wheel is a highly recommended for efficient use of BuildingWorx. The rolling the center wheel zooms in and out in the modeling window. Pressing and holding down the center wheel/button and moving the mouse pans the view of the model. A user who is familiar with these two actions can very quickly navigate around a model.

![Mouse Image]

A quick way to edit the geometry of a model element is to select the element by clicking on the label which causes the vertices of the element to be displayed. The user can click on any vertex to select the vertex and click at a new location to move the vertex. Combined with snapping to CAD background, this is a quick way to modify geometry. If the user has selected a vertex to change its location, but decides against moving the vertex, pressing the “Esc” button will cancel the move in progress.
2.2. **Editing Model Object Properties**

BuildingWorx provides object data and editing options in a single location under object properties explorer on the right side of the window. User can browse through different properties to make adjustment without the need for multiple menus or toolbars.

When a single object is selected, the full range of properties and editing options are shown in the object property explorer. In addition, several similar objects can be selected and edited at once. To select multiple objects, selecting tone object by clicking the left mouse button while the cursor is on the object, press and hold the <Ctrl> key and continue selecting additional similar objects by moving the cursor and clicking on the left mouse button.

In addition to viewing and editing the object properties using object properties explorer, many commonly used properties are accessible by context-sensitive object menus accessed by right clicking on the modeling objects.

Both the object properties browser and the right-click menus change when viewing analysis and design results.
3. **Introductory Concepts**

A few concepts and terms used in BuildingWorx are fundamental to understand how to use BuildingWorx.

**Level**: A structural model of a multi-story building in BuildingWorx is divided into levels. Each Level in BuildingWorx consists of the wall framing for a story and the floor or roof framing **above** the story.

![Figure 3-1: Levels](image)

**Wall** objects represent vertically framed wood framed walls. Walls are further classified as **bearing** or **non-bearing**, also known as a partition wall. Walls are comprised of repetitive studs and unique objects such as openings with headers, and posts. **Shear Walls** are a special type of bearing wall that also provides lateral (wind and seismic) force resistance.

**Framing Areas** represent regions of similar horizontal or sloped framing. There are three types of framing areas: **Floor**, **Ceiling** and **Roof**. Framing areas are comprised of repetitive joists (or rafters or trusses) which are defined in **Joist Areas** and can have openings and beams associated with them. Framing Areas have properties such as loading, framing orientation and framing type.

**Joist Areas** are part of a single Framing Area. By default, the properties of a Joist Areas are inherited from the Framing Area it is part of. The properties of a joist area can be disconnected from its Framing Area to make changes applicable only to the specific Joist Area.
**Beams** can be used to support walls and framing area. For a beam to support the joists the beam needs to be associated with the framing area containing the joists. Beams are associated with one or more framing areas.

**Diaphragms** are used to transfer lateral (wind and seismic loads) along the horizontal and sloped planes of the model to the Shear Walls. This document is primarily for gravity design and does not cover the use of diaphragms or shear walls.
4. Recommended Gravity Framing Design Steps

The following are recommended and practical steps to follow when performing gravity framing design using BuildingWorx.

1. Import architectural plans
2. Define levels and alignment points
3. Draw first level exterior walls and known interior bearing walls
4. Repeat for upper levels
5. Start Framing layout at top (roof) level
6. Determine framing orientation & locate interior bearing walls and main beams
7. Frame special areas (openings, low roofs…etc)
8. Frame typical areas
9. Repeat for lower levels.
10. Run analysis and review results
5. Framing Design of Example Project

The purpose of this section is to introduce the user to gravity framing design in BuildingWorx through a simple example.

The example below aims at illustrating the basics of modeling with BuildingWorx. The architectural background file for this example is available for download from Structural Soft with this Getting Started Guide.

5.1. Start a new project & input Project Information

After launching BuildingWorx, select a new project from the File menu. The program will automatically give the project a temporary name which you can change and save. The project information form will be displayed for you to fill out. This information will be used in the title and headers of the design reports and schematic layouts.

![Figure 5-1: 3D View of a Simple Example Project](image-url)
5.2. Attach Architectural Plans

The quickest way to build a structural design model is by using architectural plans in CAD format. Attach the architectural background for the Getting Started project through the menus at File > Attach DXF, or by using the Attach DXF Tool in the toolbar.
This opens a dialogue box from which you locate the dxf file and set the scale of the drawing file.

![FIGURE 5-4: ATTACH DXF DIALOGUE](image)

The default DXF Scale of 1 to 12 is typical as CAD files are commonly created using inches at the native unit and BuildingWorx uses a foot (12 inches) as the native unit.

This Getting Started Guide is best used if you open the BW-getting-started-arch.dxf example file that is available for download with the Getting Started Guide. If you cannot locate this file, visit the downloads or support sections Structural Soft website.

The DXF file containing the architectural floor plan is not explicitly imported into the BuildingWorx framing model, but is referred to similar to an external reference (X-REF) in CAD software.

The contents of the architectural background file should be visible as shown below.
5.3. **Define Levels**

To define the number of floors and typical floor elevations, select either **Framing > Edit Floors** menu item or the **Edit Floors** tool from the tool.

Note that the same graphic icon appears to the left of **Framing > Edit** menu item and on **Edit Floors** toolbar. This helps the user learn the toolbar icons by seeing the graphical icon next to the menu item.
In the dialogue, set the number of floors to 2 and then edit the plate height, framing thickness and sheathing thickness for each level as shown in the figure below. These values will be used to calculate the building elevations and wall heights.

![Edit Floors Dialogue](image)

**FIGURE 5-7: EDIT FLOORS DIALOGUE**

In order to align floors, the user needs to define a base point for each floor. This is similar to the common practice of overlaying floor plans using trace paper. The base point at any level is the point resulting from intersection for the level with a virtual vertical line selected by the user. For example, in this project, the back left corner of the house will be used as a base point.

Select base point in the first floor plan by clicking on the Pick button for the first floor in the Edit Floors dialogue. Then in the modeling window, pan and zoom as needed to select the back left exterior corner of the walls at the first floor level. When successful, select the base point for the second level as the back left exterior corner of the walls at the second floor level. When your Edit Floors dialogue matches the figure above, click OK.

### 5.4. Draw First Level Walls

BuildingWorx can be used for both lateral and gravity framing design. As this example is for gravity framing alone, verify that the “Build Lateral Model” option is turned off.
under the Analysis menu before continuing. If there is not a check to the left of the Analysis>Build Lateral Model menu item, this option is turned off.

Before drawing any walls at the first level, verify that the Active Floor is the 1st floor.

FIGURE 5-8: VERIFY CURRENTLY ACTIVE FLOOR IS 1ST FLOOR

5.4.1. Drawing Single Straight Wall

The simplest way to define a single straight wall is using the Straight Wall tool from the Walls>Straight Wall menu item or the Straight Wall Tool in the toolbar.

FIGURE 5-9: STRAIGHT WALL TOOL

Use the Straight Wall Tool to draw a wall over the full width of the front of the garage. First select the straight wall tool and then review the Properties Explorer before continuing. The wall that we are drawing is going to be an exterior Bearing wall on foundation. The exterior walls in our architectural background are 6 in thick walls so before drawing our first wall, change the Section Properties>Section Name value to 2x6.
Drawing straight walls take three clicks in the modeling area. The first two clicks define an alignment line for the wall. These can be on either face of the wall or along the center-line of the wall. A recommended practice is to click on the exterior face of exterior walls for the first two clicks of placing an exterior wall.
The third click of placing a straight wall positions the wall relative to the alignment line. After selecting the alignment line with the first two clicks, move the cursor around to see how the proposed wall position changes. Perform the third click on the interior side to position the wall correctly. After the third click, you can continue to draw additional walls, or select another tool or press the <ESC> button to activate the Selection Tool to leave the Straight Wall Tool.

If you are having challenges to position the wall correctly, verify the snap options you have selected at the bottom of the software window. Having OSnap selected at this time is essential while the rest do not need to be selected.

The Object Label for this wall is “WF1-EX-FDN”. WF1 is the object ID (Wood Framed Wall 1) which is unique for the floor level. EX means it is an exterior wall and FDN means it is on foundation.

Click on the Object Label to see the Properties of the wall as created.

5.4.2. Drawing Walls by Polyline

Having drawn our single wall at the front of the garage, a faster way to draw all of the exterior walls of the first floor is the Walls by Polyline Tool.

Before doing so, remove the straight wall at the front of the garage by selecting the Delete Tool ( ) and clicking on the wall label (WF1-EX-FDN). Then exit the Delete tool by selecting the Select Tool ( ) or pressing the <Esc> key.

To walls around the entire exterior of the building, select the Walls>Walls by Polyline menu item or the Walls by Polyline Tool ( ). Then chose “Draw Polyline” from the generate wall options.
Now trace around the exterior face of all the exterior walls of the first story level selecting the exterior corners in a clockwise direction. During the selection process, you can continue to roll the middle mouse wheel to zoom in and out and hold down the middle mouse wheel to pan the view.

![FIGURE 5-13: WALLS BY POLYLINE AROUND FIRST LEVEL](image)

After tracing around the entire building and selecting the first corner for a second time, press the <Enter> key to complete the tool action. The model should now look like the following.
5.4.3. **Interior Walls**

To draw in the interior walls of the first floor, first add the walls at the rear of the garage using Walls by Polyline. First select the Walls by Polyline Menu Item or Toolbar Icon then select Draw Polyline. Now before drawing any walls, review the Properties Explorer and change the Misc>Use property from Exterior to Interior.
Next draw the rest of the interior walls using either the Straight Wall or Wall by PolyLine Tool. Note that the rest of the interior walls are 4 inches wide, so either change the tools properties before drawing the walls or drawn the walls and then change them to be 2x4 walls.

The completed first level interior walls look as follows.
5.4.4. **Adding Wall Openings**

Next add the window openings in the first level by selecting the Opening tool in the menus at Walls>Add Wall Opening or in the Toolbar ( ). Before adding any windows, review the Properties Explorer and verify that Windows are to be added.
After verifying the properties of the openings to be added add each of the four windows on the first floor. With the Opening Tool active click once on each end of the opening within the wall segment.

---

**FIGURE 5-17: OPENING PROPERTIES**

**FIGURE 5-18: ADDING OPENING**
If all of the labels shown above are not visible, review the view options from the View>Object Text Display and View>Object Section Text Display menu items or the equivalent Tool Icons in the Visibility Toolbar.

Following adding the windows, add the four doors on the plan: at the front entry, the garage to interior, the closet by the stairs and the main garage door.

The completed model of the first floor walls looks like the following.
5.5. **Draw Second Level Walls**

Next, set the active floor to the Second Level.
The Second Level shows the background file and, with the dashed lines, the walls of the floor below. If the dashed walls of the floors below are not in-line with the upper floor walls of the background file, then likely the Alignment Base point of the Edit Floor dialogue were not accurately selected. It is important to verify the alignment between levels before drawing objects on the upper level(s).

![FIGURE 5-22: SECOND LEVEL BEFORE EDITING](image)

Draw walls around the exterior of the Second Level and add the four window openings in the walls. After drawing the walls and window, turn off the background DXF file by selecting the Show DXF Objects visibility control tool (§) in the left side Visibility toolbar and the resulting model appears as follows.

Turn back on the visibility of the background DXF file, turn off the visibility of the walls below (■) and continue on to create the upper roof framing layout.
5.6. Layout of Roof Framing

Before creating any framing, select the menu item Framing>Framing Area Settings to review the default repetitive framing members and loads.

For this example project, we’ll use trusses at the upper main roof and rafters at the minor low roof. To choose to use trusses at Roof Framing Areas, select the “Use Trusses” checkbox under the Roof section and select OK.
5.6.1. **Roof Framing Area**

The first step to define our roof framing is to define a roof Framing Area. Select the Add Framing Area tools through the menu Framing>Add Framing Area or the Toolbar Icon ( ) and then select to Draw Framing Area Polygon. The steps to input the Framing Area Polygon is similar to tracing around the exterior walls, however this time trace around the exterior eave line of the roof from the architectural plan.

When the Roof Framing Area is drawn and selected, the model and properties should look like the following figure.
5.6.2. Roof Girder Trusses

In reviewing the roof profile, three primary girder trusses will be used to support the roof as shown in the figure below. Girder Trusses are added to the model as Beams with the properties set to mark them as Girder Trusses. Trusses are not designed in BuildingWorx Framing, but they are analyzed as beams to determine the loading on the Trusses and the reactions to the supports. Accurately layout of trusses in the software not only captures the design intent of the design professional, it also allows the software to track the forces from the roof through the rest of the structural system.
To draw the first Girder Truss running right to left, select the draw beam tool through the menu Framing>Draw Beam or the Toolbar Icon (Beam). Then in the Properties Explorer verify or set the Section Properties>Is Girder Truss to True.
Next draw the beam from the interior corner of the reentrant corner to the left edge of the roof. Placing the beam is similar to placing a straight wall. Two clicks define the alignment line and the third click defines the position of the beam (or girder) relative to the alignment line.

For this truss, the points are chosen to align the rear edge of the girder truss with the inside edge of the parallel wall.

**FIGURE 5-28: FIRST CLICK OF GIRDER TRUSS**

**FIGURE 5-29: SECOND CLICK OF GIRDER TRUSS**
The two girder trusses running front-to-back on the roof are to be located at an 8 foot set-back from the eave edge of the roof. To position these trusses precisely, we need to perform a “drafting” task to determine the alignment point of the truss.

This task is to draw a line exactly 8 ft in length from the left rear roof corner along the rear edge of the roof. Start by selecting the Draw Line tool from the menu Draft>Draw Line or the Toolbar ( ). Next select the left rear corner of the roof using the OSnap cursor snapping behavior.

While the selection cursor is still on same corner as shown below, press right arrow key (→).
FIGURE 5-32: AFTER SELECTION OF CORNER WITH CURSOR ON CORNER

The right arrow key is a keyboard shortcut to perform a precise movement of the selection cursor. Notice the Hint Area at the bottom of the window giving you instructions as the next expected step. Press the number “8”, for 8 feet, and the hint area should look like the following:

FIGURE 5-33: THIRD CLICK OF GIRDER TRUSS

Now press <Enter> to finish the dimension desired, and then press <Enter> again to finish the line drawing tool. The results should look like the following.
To verify the length of the line, try using the Horizontal Dimension tool from the menu Draft>Dimension-Horizontal or the Toolbar ( ).

The precise dimensioning of edits using the arrow keyboard shortcut can be used with drawing many different objects including setting the lengths beams and walls. The dimension can be typed in several formats:

- Feet 8 means 8’ 0”
- Decimal Feet 8.5 means 8’ 6”
- Feet and Inches 8’ 6 means 8’ 6”

To draw the Girder Truss running right to left, select the draw beam tool through the menu Framing>Draw Beam or the Toolbar Icon ( ). Then in the Properties Explorer verify or set the Section Properties:Is Girder Truss to True and Misc:type is Flush_Top.

To properly position the truss with the Beam Tool, first select the right end of the 8 foot drafting line as the first alignment point of the truss. For this to work the OSnap Snap option must be selected.
To select the second alignment point of the truss, scroll and pan down to the first drawn girder truss and locate the point on the truss where the orthogonal snap option shows on the close face of the first truss as shown below and click on this point.

For the third click, to place the truss relative to the alignment points, click to the right side of the truss. This will place the left edge of the truss at 8 feet from the left edge of the roof. Now to exit the Beam Tools press the <Esc> key.

After the girder truss has been positioned and drawn, the drafting line can be deleted.

To visually emphasize the drafting line, use the visibility control toolbar on the left of the window turn off the visibility of the Framing Areas by left clicking on visibility tool( ) and turn off the background DXF by clicking on the visibility tool ( ). The modeling window will look like the following.
To delete the drafting line, select the Delete Tool ( ), click on the drafting line which will delete the line, and then press the <Esc> key to exit the Delete Tool.

Now using the visibility control toolbar, turn on the visibility of Framing Areas ( ) and the background DXF ( ) back on. This can be done by clicking on the visibility control icons for both object types turned off, or simply by clicking on the show all visibility icon ( ). We can also turned off the walls below ( ) to simplify our current model view.

Using the same sequence of edits add the girder truss at the right side of the roof at a similar 8 foot set-back from the right edge of the roof line. For this truss the front end of the truss will be at the front edge of the roof instead of at the previously drawn truss.
5.6.3. **Fill Roof Framing**

To fill the entire roof with trusses, select the Fill Framing Area at the menu item Framing>Draw Joist Area>Fill Framing Area or by selecting the Fill Framing Area tool ( ). If you don’t see this exact tool, it is part of the Framing Area Toolbar group, which may look like ( ) or ( ). Left click on the triangle right of the icon and you should see a drop down with options including the Fill Framing Area tool.

After selecting the Fill Framing Area tool, in the following dialogue, select the Framing Area previously created (FA1) and press the OK button.

The framing area is now filled with trusses running left to right and should look like the following.
The Framing Area is filled with a single Joist Area where all the trusses have the same orientation and loading. Zooming into the top left corner, note the following details:
The trusses have been automatically split at the girder truss and each truss has a label. Also note the green hanger graphics showing the assumed support type of the truss by the girder truss. The yellow box means that there is support of the truss at the girder truss and exterior bearing wall. These same graphics will apply to all repetitive framing area members: joists, rafters or trusses.

Looking at the roof plan, most of our trusses should run front to back, so select the framing area label **FA1** near the middle of the roof to review and modify the framing area properties in the Properties Explorer. Select the orientation and change the value to 90 degrees. At this point you could also change this loads on this particular framing area if they varied from the default values reviewed or modified in the Framing Area Settings available at the menu Framing>Framing Area Settings.
After changing the orientation, the model appears as follows.

Next, click on any joist line to select the Joist Area and review the Properties Explorer for the Joist Area:
To more accurately layout the roof, add a hip Girder Trusses at each hip of the roof using the beam tool. The hip trusses should be centered under the hip lines. After drawing the hip truss, note the red portion of the truss lines. The red portion of the truss is the length cantilevered off the support at the corner of the walls.
Next we will split the single Joist Area into multiple Joist Areas where the orientation needs to be changed. There are two tools to perform such splits. Split Joist Area by Line (\textcircled{1}) and Split Joist Area by Polyline (\textcircled{2}). Use these tools to split the joist area along the hip and center of beam lines as shown in the following figure. When using the tools, pay attention to the Hint Area of the screen to look for instructions.
After performing the above splits, rotate the orientation of the various joist areas by left clicking on a truss to select the Joist Area and then right clicking to see Joist Area quick edit options. In the right click menu select “Rotate 90 Degrees” to change the orientation of the joist areas.
5.7. **Layout of First Level Framing**

Now we will layout the first level framing, starting with the framing areas, then beams and finally the floor joists. Return to editing the first level by selecting the Active Floor = 1st from the Active Floor Tool.

5.7.1. **First Level Floor Framing Area**

Start defining the first level floor framing area by defining a Framing Area covering the second floor starting immediately behind the low roof and extending around the first story walls using the Framing Area tool ( ). The Framing Area appears as follows:

![FIGURE 5-48: FIRST LEVEL FLOOR FRAMING AREA](image)

Next select the Framing Area label FA1 and review the Properties Explorer. Note that the Area Use has been automatically selected as “Floor” and the default framing members and loads initialized using the Framing Area Settings.

Now add an opening around the stair area using the Add Opening Tool ( ). Select the tool, chose to draw a new opening from the options, and then click around the perimeter of the stair opening and pressing <Esc> when the opening is complete as shown below.
5.7.2. **First Level Floor Joists**

Next we will fill the floor area with floor joists. To fill the entire floor area with a single joist area, select the fill Framing Area tool in the menu at Framing>Draw Joist Area>Fill Framing Area, or in the Toolbars ( ). Chose the tool, select to fill the Framing Area “FA1” and press OK. The model should look like the following with joists shown spanning most of the floor area.
If you do not see any joist, verify that “Show Joists” icon in the Visibility Tool bar is selected.

You’ll immediately notice that joists are not shown over the entire floor area. Also note that there is no structural support for them at the right edge of the stair opening. We need to resolve this by adding a beam at the edge of the opening.

5.7.3. **First Level Beams**

To add a beam at the edge of the stair opening, select the Draw Beam tool and drawing a beam aligned with the edge of the opening. After placing the beam, recall to press <Esc> to leave the Draw Beam tool. The Draw Beam tool stays active after drawing a beam to allow the user to quickly draw many beams in a plan without having to re-select the tools for each beam.
This beam is shown as a flush beam using the default beam size. A 4x10 beam does not match the depth of our floor system, so we will now change the selected section for the beam. Select the beam by left clicking on the beam line or the beam label (B1). Then in the properties explorer left click on the Select Selection Field.
To match the depth of the floor system, in the resulting dialogue box, select a Boise Cascade Versa Lam LVL section as shown below and click OK.
The section of the beam should now be shown as 1.75x11.875 in the modeling window. While we work on the beams, it may be useful to not show the joists. To turn off the Joists using the Visibility Toolbar icon.

Note the beam is narrower but remains aligned with the edge of the opening.
Now, to reduce the long span of the joists at the gap in the central wall opening, let’s add a dropped beam at that location. This time, select the center of the yellow dashed line of shown near each end of the two adjacent walls as shown below.

This yellow dashed line is located 1.75 inches from the end of the wall is a graphical aid to layout objects. While not necessary in this configuration, the snapping to the yellow dashed line can be used to place a beam over the center of a 4x post located at the end of the wall.

Now select the beam (B2) and in the Properties Explorer, change the property Misc> Type to be Dropped. While the beam is still selected, it will look like the following.
To see the impact of this beam on our joists, turn on the Joists using the Visibility Toolbar icon ( ). The joists still run continuous over the wall opening, but now there is a yellow square at the joists over the new beam representing the joists are supported by the beam.

### 5.7.4. Low Roof Framing

Using the skills exercised above, draw in a Framing Area for the low front roof. Do this by using the Framing Area tool ( ), however this time you can draw a rectangular area. Instead of using trusses, we will frame this low roof using 2x6 rafters. After drawing the Framing Area, select the Framing Area (FA2) and modify the properties of the Framing Area to be a roof area with 2x6 sawn lumber and a 90 degree orientation as shown in the figure below.
To support this low roof and the unaligned second story wall over the garage, we need to add a beam at the front edge of the floor framing. Let us try a 3 1/2 in by 11 7/8 in manufactured beam.

To place this beam in a different manner than the previous beams, select the Beam By Layout Tool ( ) through the Framing Menu or Toolbars. The Beam By Layout Tool allows you to create a beam by defining the alignment line in the direction you want the beam located and the beam will be automatically extended to the nearest supports in the directions of the alignment line. For this beam, select the intersection of the low roof hip lines with the edge of the low roof as the alignment lines as shown below. In this case we use the front edge of the beam as the alignment line so that no matter what width of beam selected, the edge of the beam will remain at the same location.
After the entering the beam based upon the hip intersection points, the beam is created spanning from one bearing wall to the other on each side of the garage.

Select the resulting beam and change the section to a 3.5x11.875 Boise Cascade Versa Lam 3100 PSL beam. The resulting beam and properties should look like the following:

Next, fill in the framing area with the roof framing using the Fill Framing Area tool in the menus at Framing>Draw Joist Area>Fill Framing Area or by selecting the Fill Framing
Area tool ( ). Next split the resulting Joist Area using the Split Joist Area by Line Tool ( ) along the two hip lines and rotate the two side Joist Areas 90 degrees by using the context sensitive right-click menus. To use the right-click menus, first left click on the label of the joist area, e.g. “J2 Type=Roof” so that it is selected, and then right-click the mouse and select “Rotate 90 Degrees” from the in-place menu. The resulting layout will look like the following, where the need to support the rafters along the hips is apparent.

FIGURE 5-60: FLOOR BEAM AT GARAGE

Add two beams along the hip lines from the exterior corner of the roof plans to the edge of the left-to-right beam. After adding the beams, you may need to reset the supports of the Joist Areas for the software to properly recognize the supports of the Joist Area and generate the full framing. Use the “Reset Supports” entry of the right-click context sensitive menu for the Joist Area (J2, J3, J4).

The default 4x10 section size for the hip beams is likely larger than needed, so let us change these to 2x10s. Select one hip beam and then either through the right-click menu or the Properties Explorer, change the selected section to a 2x10.

Now instead of performing the same action on the second beam, let use the Match Properties Tool ( ) took copy the properties from the modified hip beam to the other hip beam watching the hint area of the interface for instructions on how to use the tool.
5.8. Analysis and Design

Our model is now ready for analysis and design.

5.8.1. Running the Analysis

To run the analysis, chose the Analysis>Run Analysis, select the Analysis Tool ( ) or press F5. In the Analysis Options dialogue, select “Solve For Framing” and Joists, Beams, Headers, and Posts.

The model verifier windows may now open. There are two types of messages from the model verifier: errors and warnings. Errors prevent the analysis from running and must be fixed before the analysis will complete. Warnings are important messages for the user to know about. If you have no errors press OK to continue through the analysis.
As the analysis progresses, messages will be displayed in the hint area of the interface and when the analysis is complete, the total load verification table will be displayed. This dialogue presents the total load onto the framing members and compares them with the total loads applied to the foundation.

5.8.2. Reviewing Results Overview

There are several ways to explore and view the results of the analysis and design checks:

- In the graphical model view where the governing demand to capacity ratio is displayed
- In member specific right-click menus accessing member reports, load diagrams and re-design options
- In analysis results table available under the Results Menu and
- In analysis reports available under the Reports Menu.

To control which design checks are visible in the graphical model view, select the Object Text Control tool through the View>Object Text Control Menu or the Visibility
Toolbar Icon ( ). Verify or select to display the DesignCodeCheck for beams, openings (e.g. headers) and Joists. For headers and beams, the graphical design results look like the following with is for the garage door header.

**FIGURE 5-63: GRAPHICAL DESIGN RESULTS**

### 5.8.3. Review of Header Designs

As seen in the previous figure, the garage door header is overstressed. To modify the selected section, use the right-click menus to select the “Re-Design menu item”. Left-click on the header label or size and while the header is selected, right click and select “Re-Design”. This brings up a dialogue box with allow a quick change of the selected section with a summary of the allowable stress and deflection checks.

Change the Species/Grade and Section Type/Name to a Doug Fir #1 6x10 as shown in the following dialogue.
After selected the new acceptable section for the beam and selecting OK, the graphical view is updated for the new size and stress ratio.

To look at the calculations for this header in more details, use the right-click menu Design Details to see a dialogue showing many more details and options, including adjustment factors and calculations for each load combinations.

Also note in the right-click menu the “Include In Reports” line. By default, detailed calculations on headers are not included in the analysis reports for the building. Select the “Include in Reports” item and a check-box will be displayed next to the menu item and the garage opening header will be included in the overall calculation reports.

Other results items to review for the garage door header are the Design Report and Load Diagrams items each available from the right-click menu of the member.
FIGURE 5-65: DESIGN REPORT EXAMPLE
To see a summary of all of the header design results, select the Results>Framing>Header Design menu item.
5.8.4. **Review of Floor Beam**

A review of the graphical results of our analysis reveals that the initial assumption of an 3 ½ by 11 7/8 beam over the garage supporting the wall above and low roof is inadequate. As in the header above, right-click select the “Re-design” menu item and chose a 5 ¼ x 11 7/8 beam for this location. Also note that the “Include in Reports” check is selected by default for this beam. All beams, unlike headers, are included in the summary analysis reports by default.

Additional details on the beam results are available through the right-click menus and Results menu as with headers.

5.8.5. **Floor Joist Redesign**

Further reviewing our design results in the graphical model viewer, we may note that the floor joists on the right side of the building are shown as being overstressed.
Also note the two solid red dots or filled circles. These represent large point loads coming from the upper level without a lower level supporting post.

To change the joist type or add posts, we need to unlock the analysis results by selecting the Analysis>Unlock Results menu, the Toolbar Icon (🔒) or Shift-F5.

Recall that our Joist Areas for the first floor framing are all connected to the Framing Area, FA1, in the above figure. To change the joists selected for the floor framing, select the Framing Area, FA1, and then in the Properties Explorer, change the Grade to BCI 6000-2.1.

To add lower level posts below the posts above supporting the main girder truss, first zoom into the interior re-entrant corner on the lower level as shown below.
Now add a post aligned with the post above using the ToolBar Icon ( ). Adding a post uses two clicks. The first click selects an alignment point which is one of the four corners of the post or the center of the post. The second click positions the post relative to the first alignment click. If you need to, you can add the post and then use the right-click menu for the post to rotate the post 90 degrees.
Repeat this process again for the point load on the left wall directly left of the reentrant corner and rerun the analysis.

After running the analysis, if we look at the graphical results, we see the newly selected floor joist has a demand to capacity ratio of 101%. Looking into the Design Details of the floor joists, we see this is a live load deflection check which we’ll assume is acceptable.

5.8.6. Framing Reports

Calculations reports for the framing members are available through the Reports>Framing Reports menu. For each beam and header that has been selected to be included in the reports will generate calculations in the framing report.

The menu Reports>Framing Layout can be used to generate useful schematic layouts of the resulting design items.
FIGURE 5-71: FRAMING SUMMARY REPORT GENERATION
5.8.7. **Export Structural Plans as CAD File**

If we are complete with our design, a powerful feature is the ability to export the structural design to the CAD files using a DXF file format.

This capability is available under the File>Export DXF menu item with many configurations options available at File> DXF Export Settings.

5.9. **Introduction to Section Groups**

The information above can be used to complete a design of a building, but a powerful additional feature is working with Section Groups. Section Groups are used to automatically select the most preferable section from a list, the Section Group, by having the software automatically chose the first section in the list that meets the design criteria for loading applied to the member. You can set up Section Groups to capture your design preferences for a type of framing member such as headers in 4 in thick walls, and then the software will automatically chose the members based upon your preferences.
To see Section Groups in practice, the software come with several Section Groups created for you. If you have not done so, unlock the analysis results from above using the Toolbar Icon (†).

Next select all of the window and door opening in the exterior walls of the first floor walls. This can be done by first selecting one opening and then while holding the Control key down, panning and zooming around the model and clicking on the remaining five openings, including the garage door opening, for a total of six. With all five selected, in the Properties Explorer, set the entry Section Properties>Section Group to “6-hdr”. This section group lists 6x6, 6x8, 6x10 solid sawn members and then continue to engineered lumber of higher strength.

Re-run the analysis to see the impact of this selection. In this particular example all of the exterior header openings except the garage door opening have been set to 6x6 headers while at the garage door opening a 6x10 is selected.